Takeover HTML_Template_IT

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

Takeover HTML_Template_IT

Greg Butler
The HTML_Template_IT package last had a release on 2010-03-10.  It is
currently broken due to use of a deprecated feature that is no longer
supported in PHP 7.0+.  A bug report for this was filed earlier this
year but no action has been taken.  I emailed the one person who is
listed as an active maintainer but have received no response.

The package also triggers other deprecation warnings that will likely
become a problem in the future.  I'm sure that there are many people who
have not yet upgraded to PHP 7 who will run into these issues when they
do.  I would like to get them fixed before that happens.  So I am
requesting to be added to the project so I can do this.

Also I'm not sure if I will see responses to this message.  I have
requested twice at http://pear.php.net/support/lists.php to be added to
this list.  The page displayed a message that I would be contacted with
instructions to complete my registration but no such messages were ever
received.  I checked my junk and there is nothing, so I seem to be
unable to join this list.  I hope that somehow I can get this package
fixed.  Thanks.

--
PEAR Development Mailing List (http://pear.php.net/)
To unsubscribe, visit: http://www.php.net/unsub.php

Reply | Threaded
Open this post in threaded view
|

Re: Takeover HTML_Template_IT

Chuck Burgess-2
Hello Greg,

The existing codebase is available on Github at
https://github.com/pear/HTML_Template_IT.  If you can make some PRs with
the changes you're looking for (target the master branch, not trunk), I can
see about getting them merged and a new QA release rolled out.  Successful
PRs can usually be enough of a threshold to grant membership into a
project, especially a dormant one.

CRB
*about.me/ashnazg <http://about.me/ashnazg>*

On Mon, Dec 25, 2017 at 12:09 PM, Greg Butler <[hidden email]> wrote:

> The HTML_Template_IT package last had a release on 2010-03-10.  It is
> currently broken due to use of a deprecated feature that is no longer
> supported in PHP 7.0+.  A bug report for this was filed earlier this year
> but no action has been taken.  I emailed the one person who is listed as an
> active maintainer but have received no response.
>
> The package also triggers other deprecation warnings that will likely
> become a problem in the future.  I'm sure that there are many people who
> have not yet upgraded to PHP 7 who will run into these issues when they
> do.  I would like to get them fixed before that happens.  So I am
> requesting to be added to the project so I can do this.
>
> Also I'm not sure if I will see responses to this message.  I have
> requested twice at http://pear.php.net/support/lists.php to be added to
> this list.  The page displayed a message that I would be contacted with
> instructions to complete my registration but no such messages were ever
> received.  I checked my junk and there is nothing, so I seem to be unable
> to join this list.  I hope that somehow I can get this package fixed.
> Thanks.
>
> --
> PEAR Development Mailing List (http://pear.php.net/)
> To unsubscribe, visit: http://www.php.net/unsub.php
>